New

Error #14, #17, #42

I bought a Lima hoping to make backing up my phone, laptop (Mac) etc easier, instead it's been one frustration after another. I'm in Australia, bought 2 x Lima and had them shipped. They arrived with no Aus power adapter after being told that it would. Not a big deal, only a couple of $. Then I bought a brand new HDD meeting all the Lima requirements. No luck. I seem to get mostly Error #14 and Error #17 with a few Error #42s just to mix things up a bit. That's if the installation even finds my Lima in the first place.

Then I tried to email for support. When I finally got a response, I was asked the same question 3 times and given the exact same response all 3 times. Trialled everything they recommended. No change. Then I was told that my HDD needed a powered hub, which I had to buy. Still no difference. Then I was told BOTH my Limas are broken to I should ship them back to France at MY expense to get new ones or a refund.

Is this company a sham or do these things actually work for anyone else? I think I'm going to cut my losses and give up unless anyone has any other bright ideas other than uninstall-reinstall, reboot, try again...