Need Answer

i386

Sorry, I am sure this has to be somewhere, bit I didn't find it.

I have Ubuntu Mate 16, and the deb installer tells me wrong architecture (is i386, should be amd64).

Am I right guessing that it means I have the 64bit problem (I understand there is no version for 32bit), or can it be that the i386 runs 64 anyway? Sorry my ignorance

andres